The Latest in IT Security

This plugin will warn you immediately when you visit a site affected by Heartbleed

10
Apr
2014

Heartbleed is one of the most widespread vulnerabilities we have seen in recent years — it impacted an estimated 66% of the entire Internet at the time of its discovery. The bug affects OpenSSL, which is a popular security protocol used to encrypt sensitive data sent to and from websites. Major sites such as Yahoo, Flickr and Imgur are among the sites that were affected by Heartbleed, potentially exposing users’ passwords and other data to hackers. While many have patched the bug and others continue to do so, it will be months or even years before every site addresses the issue. In the meantime, a simple free Chrome browser plugin will alert users when they visit a website that is still

Comments are closed.

Categories

THURSDAY, JUNE 21, 2018

Featured

Archives

Latest Comments

Social Networks